Windows/CrowdStrike Outage
Incident Report for Chronotrack
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 07:56 MDT
Monitoring
We are aware of the major outage affecting Windows users globally following a CrowdStrike update.

We would like to assure our customers that Chronotrack and Athlinks are not impacted by this outage. All Chronotrack and Athlinks services are operating normally and without interruption. We will continue to monitor the situation throughout the weekend.
Posted Jul 19, 2024 - 13:30 MDT
This incident affected: ChronoTrack Live (CTLive Admin Portal, CTLive Registration, CTLive Results API, Media Manager) and ChronoTrack Timing (CCS Service, Timers Portal).